System Maintenance
Incident Report for Whip Around
Resolved
All resolved within 30 mins.
Posted Jun 22, 2017 - 02:11 EDT
Identified
We are conducting system maintenance with will take between 60-120 minutes. Apologies for any inconvenience caused.
Posted Jun 22, 2017 - 01:31 EDT