Android app not working
Incident Report for Whip Around
Resolved
The Android app connectivity issue has been resolved.
Posted Aug 09, 2018 - 11:02 EDT
Investigating
We are currently investigating this issue.
Posted Aug 09, 2018 - 08:46 EDT
This incident affected: Android Application.